Q&A (#2) - Bailout from CCR (#6) - Message List

Bailout from CCR

Can someone give me a quick run-down on how best to do this.

I thought at first that I should add it as a new level but that doesn't seem to work and no switch to OC happens.

The only way I can see it works is by inputing my bailout gas in the deco gas screen and selecting OC at max depth/time.

I can see the switch in the profile window now but am unsure whether this is the way to do it. Indeed in the profile it doesn't seem completely clear where the switch to OC occurs. i.e. First mention of the OC gas in the profile is at 1st stop.


  • Message #2

    Hi Broady,

    Adding a 1min level after your CCR level should work, here's a screen-shot of how I did it using 0.9 ;

    http://eskil.org/pics/baltic/BalticCCRBailout.0.9-3.png http://eskil.org/pics/baltic/BalticCCRBailout.0.9-1.png http://eskil.org/pics/baltic/BalticCCRBailout.0.9-2.png

    The 1st picture is the normal CCR profile, then in the 2nd I add a 1 minute level using OC, and now in the profile (3rd picture), the second level uses air but does not have a ppO2 setpoint - that's the OC switch (also marked by the green highlight).

    But that sounds like exactly what you did ? So I'm left wondering why it didn't work for you ?

    Adding it as deco will not accomplish the same, since it won't switch to the OC gas until you get to the first deco stop.

    The underlying code already supports bailout, but the UI isn't entirely done yet. But it will be in a new release that will probably be posted to the AppStore before the end of february. I had actually already posted the screen-shots on BalticScreenShots, down at the bottom. It will let you tap on any level or decostop and compute a bailout profile (both wreck/cave and normal) from that point.

    It also lets you configure gases for bailout only, so you can do OC deco, and have gases that are used for the bailout plan but not for OC deco in the normal plan.


    • Message #3

      Thanks Eskil - it ws the 1 min that I was missing

      Broady :)

      • Message #4

        Hmmm...at least I thought it was until I tried it.

        Makes no difference on mine at all.

        Here are my Ascent/RMV settings (I usually use metres but converted to imperial to help!) . Ascent: 33 fsw/min Descent: 65 fsw/min

        Last stop: 20 fsw Step interval: 10 fsw

        OC RMV: 0.9 cuft/min Deco RMV: 0.5 L/min

        CCR MOR: 1.0 L/min Deco CCR MOR 1.0 L/min . . . Levels: (I copied yours above)

        100 fsw, 30 min, air @ 1.3

        100 fsw, 1 min, air

        I am definitely selecting OC for the 1 minute additional level

        I do not get the green blob and the Profile is on CCR only as follows;

        100 fsw / 28:28 min

        air @ 1.3

        100 fsw / 1min

        air @ 1.3 *** here's the minute but no switch to OC ***

        53 fsw

        offgassing begins

        29 fsw/ 1min

        air @ 1.3

        20 fsw/ 1min

        air @ 1.3


        CNS = 21 OTUs = 36

        Have no idea what can be wrong - helllpp !!!

        • Message #5

          Hi Broady,

          Ah, now I can reproduce it. You've picked zhl16b, whereas I was using vpm/b. With zhl16b I see the same result as you, including the stop at 29fsw - the zhl16b implementation obviously has a bug when dealing with this.

          With vpm/b the numbers look right. It did get more testing attention during the latter days since it's more complex to implement.

          Thanks for pointing this out! I'll get on it immediately!


        • Message #6


          I've filed a ticket for this. Thanks again.



No attachments created.