Ticket #45 (closed defect: worksforme)

Opened 8 years ago

Last modified 8 years ago

Dives with any level of complexity hang the app when using ZHL-16

Reported by: ltowles@… Owned by: eskil
Priority: blocker Milestone:
Component: Unknown/Unsure Version: 0.9.8
Severity: Must Have Keywords:
Cc: Fixed in Version:

Description

Steps to replicate:

Set a GF of 10/80
Add a level to a dive of 85 feet on air for 45 min, works as expected
Change the level to 90 feet - wait spinner appears and will not go away

Notes:

Any combo of time vs depth vs GF that creates enough deco will replicate the issue
Doesn't happen on VPM
Didn't happen on previous version

Change History

Changed 8 years ago by eskil

  • status changed from new to accepted

Unable to reproduce, emailed submitter a followup to ask for more info. There might be something else in the settings that I'm missing.

Changed 8 years ago by eskil

  • status changed from accepted to closed
  • resolution set to worksforme

Turns out rebooting device the fixes the problem so it is possibly memory fragmentation on device. It could also be a slow leak in the app, will keep an eye out for that.

Closing ticket.

Note: See TracTickets for help on using tickets.